Contents

EIGRP Neighborships

Last updated: May 12, 2015

Load the task1-2 initial configurations before starting.

caption

Task

In this task you will experience how various configuration changes affect EIGRP neighborships. The idea is to intentionally implement a configuration change that will break the EIGRP neighborship between two routers, view any syslogs and/or debug output, and then resolve the problem.

  • On Router-2, copy the existing EIGRP configuration into a text editor and change the Autonomous System to AS 200.
  • Remove the existing EIGRP configuration from Router-2 and paste in the revised version (with the wrong Autonomous System number) back into Router-2.

Router-2 Configuration

Router-2#sh run | section eigrp
router eigrp 100
 network 1.2.1.0 0.0.0.255
 network 2.4.2.0 0.0.0.255
Router-2#

Router-2 with changed configuration

Router-2(config)#no router eigrp 100
Router-2(config)#
Router-2(config)#router eigrp 200
Router-2(config-router)# network 1.2.1.0 0.0.0.255
Router-2(config-router)# network 2.4.2.0 0.0.0.255
Router-2(config-router)#end

Verification

You should notice that when two routers have mismatched EIGRP Autonomous Systems, there is absolutely no indication of that problem in any syslogs. And no matter what debug you attempt to enable, you will not see any indication of this problem.

Task

  • On Router-2, remove the existing EIGRP configuration and reconfigure it to be in the proper Autonomous System (AS 100). Ensure that Router-2 has regained both of its EIGRP neighbors before proceeding to the next bullet.
  • On Router-2, reconfigure interface FastEthernet0/0 with the following IP address parameters:
    • An IP address of 2.2.2.2 /24 as the primary address.
    • An IP address of 1.2.1.2 as the secondary address.
  • Observe the affect (on both R1 and R2) that your IP addressing change has on the EIGRP neighborship between routers R1 and R2.

Router-2 Configuration

Router-2(config-router)#int fast 0/0
Router-2(config-if)#ip address 2.2.2.2 255.255.255.0
Router-2(config-if)#
Dec 15 13:43:59.130: %DUAL-5-NBRCHANGE: EIGRP-IPv4 100: Neighbor 1.2.1.1 (FastEthernet0/0) is down: interface down
Router-2(config-if)#ip address 1.2.1.2 255.255.255.0 secondary
Router-2(config-if)#end

Router-2 Verification

On Router-2 you should notice that every few seconds it declares Router-1 as its neighbor, and then a few seconds later the neighborship with Router-1 goes down indicating that "retry limit exceeded".

Dec 15 13:44:15.842: %DUAL-5-NBRCHANGE: EIGRP-IPv4 100: Neighbor 1.2.1.1 (FastEthernet0/0) is up: new adjacency
Router-2#
Dec 15 13:45:35.354: %DUAL-5-NBRCHANGE: EIGRP-IPv4 100: Neighbor 1.2.1.1 (FastEthernet0/0) is down: retry limit exceeded
Router-2#
Dec 15 13:45:38.246: %DUAL-5-NBRCHANGE: EIGRP-IPv4 100: Neighbor 1.2.1.1 (FastEthernet0/0) is up: new adjacency
Router-2#
Dec 15 13:46:57.774: %DUAL-5-NBRCHANGE: EIGRP-IPv4 100: Neighbor 1.2.1.1 (FastEthernet0/0) is down: retry limit exceeded
Router-2#
Dec 15 13:47:02.126: %DUAL-5-NBRCHANGE: EIGRP-IPv4 100: Neighbor 1.2.1.1 (FastEthernet0/0) is up: new adjacency
Router-2#

Router-1 Verification

On Router-1 you should notice that roughly every 15 seconds an error message is reported indicating receipt of EIGRP Hello packets from a connected router that does not share the same IP subnet as Router-1.

Dec 15 13:49:28.410: %DUAL-6-NBRINFO: EIGRP-IPv4 100: Neighbor 2.2.2.2 (FastEthernet0/0) is blocked: not on common subnet (1.2.1.1/24)
Router-1#
Dec 15 13:49:42.522: %DUAL-6-NBRINFO: EIGRP-IPv4 100: Neighbor 2.2.2.2 (FastEthernet0/0) is blocked: not on common subnet (1.2.1.1/24)
Router-1#

From Router-2's perspective, it is receiving EIGRP Hello packets sourced from the primary (and only) IP address of Router-1 (1.2.1.1). Router-2 does have this subnet configured on its interface as a secondary subnet so it attempts to send an EIGRP Update packet to Router-1.

Router-1 (as is seen by the Syslogs) is blocking Router-2 because the source IP address of Router-2's EIGRP Hello's (2.2.2.2) is not from a subnet that Router-1 recognizes on the link they share. So when Router-1 receives the EIGRP Update from Router-2, it simply discards it without sending any kind of reply.

Because EIGRP has reliability built in to the protocol, Router-2 attempts to resend the EIGRP Update to Router-1 several times before giving up, and bringing down the neighborship with the message, "retry limit exceeded".

Task

  • On Router-2, remove all IP addresses from interface FastEthernet0/0 and reconfigure the address of 1.2.1.2/24 as the primary (and only) IP address on this interface.
  • On Router-2, issue the command show ip protocols and write down the values you see under the EIGRP section, for Metric Weights.
  • On Router-2, change the metric weights (K-values) to anything other than the default values and notice what happens to the EIGRP neighborship between R1 and R2.

Router-2 Configuration

Router-2#sho ip protocols
...
<output omitted for brevity>
...
Routing Protocol is "eigrp 100"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Default networks flagged in outgoing updates
  Default networks accepted from incoming updates
  EIGRP-IPv4 Protocol for AS(100)
    Metric weight K1=1, K2=0, K3=1, K4=0, K5=0
    NSF-aware route hold timer is 240

Router-2(config)#router eigrp 100
Router-2(config-router)#metric weights 4 2 1 3 4 5
Router-2(config-router)#end
Router-2#
Dec 15 14:03:17.398: %DUAL-5-NBRCHANGE: EIGRP-IPv4 100: Neighbor 1.2.1.1 (FastEthernet0/0) is down: metric changed
Dec 15 14:03:17.398: %DUAL-5-NBRCHANGE: EIGRP-IPv4 100: Neighbor 2.4.2.4 (FastEthernet0/1) is down: metric changed
Router-2#
Dec 15 14:03:19.142: %SYS-5-CONFIG_I: Configured from console by console
Dec 15 14:03:19.718: %DUAL-5-NBRCHANGE: EIGRP-IPv4 100: Neighbor 2.4.2.4 (FastEthernet0/1) is down: K-value mismatch

On Router-2, change the metric weights (K-values) back to their default values.

Router-2 Configuration

Router-2(config)#router eigrp 100
Router-2(config-router)#metric weights 0 1 0 1 0 0
^ back to top