Contents

Task 1.1 - Basic Configuration

Last updated: July 21, 2016

Diagram

Tasks

  • Shutdown the interfaces as per the information provided below.
    • Sw1 : interface range fa0/11 - 12, fa0/14 -15
    • Sw2 : interface range fa0/11 - 12, fa0/16 - 18
  • Configure the hostname on all switches.
  • Configure IP addresses on all switch management interfaces as follows:
    • Sw1 : 10.1.1.1/24
    • Sw2 : 10.1.1.2/24
    • Sw3 : 10.1.1.3/24
  • Configure default-gateway 10.1.1.10 on all switches.
  • Configure Sw1 as the telnet server using the password cisco.
  • Configure the enable password cisco on Sw1.
  • You should be able to telnet Sw1 from Sw2 and Sw3.

Configuration

By default, Cisco switches have VLAN 1 as their management VLAN. We can assign an IP address in the VLAN 1 interface, which is used to access that particular switch via remote access tools such as Telnet, SSH, etc.

The switch is a Layer 2 device, which should be configured with a default-gateway using the ip default-gateway command to make it accessible from different networks. Unlike a Layer 3 device, it cannot route the packets because it only works based on the destination mac address.

First, perform the basic configurations such as hostname, IP address, and default-gateway.

Sw1:
enable
!
configure terminal
!
hostname Sw1
!
interface vlan 1
 ip address 10.1.1.1 255.255.255.0
 no shutdown
!
ip default-gateway 10.1.1.10

Sw2:
enable
!
configure terminal
!
hostname Sw2
!
interface vlan 1
 ip address 10.1.1.2 255.255.255.0
 no shutdown
!
ip default-gateway 10.1.1.10

Sw3:
enable
!
configure terminal
!
hostname Sw3
!
interface vlan 1
 ip address 10.1.1.3 255.255.255.0
 no shutdown
!
ip default-gateway 10.1.1.10

Now configure Sw1 as the telnet server.

Sw1:
line vty 0 4
 password cisco
!
enable password cisco

Verification

Initially, we can check for the IP addressing and reachability information between all the switches in this topology. When it is successful, we can check for the telnet session to Sw1 from Sw2 and Sw3. We can use some kind of output modifier to get clean output, as shown here.

Sw1#show ip interface brief | exclude unassigned
Interface              IP-Address      OK? Method Status                Protocol
Vlan1                  10.1.1.1        YES manual up                    up
!
Sw1#ping 10.1.1.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.2, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 1/2/8 ms
!
Sw1#ping 10.1.1.3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.3, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 1/3/9 ms
!
!
Sw2#show ip interface brief | exclude unassigned
Interface              IP-Address      OK? Method Status                Protocol
Vlan1                  10.1.1.2        YES manual up                    up      
!
Sw2#ping 10.1.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
!
Sw2#ping 10.1.1.3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.3, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 1/3/4 ms
!
!
Sw3#show ip interface brief | exclude unassigned
Interface              IP-Address      OK? Method Status                Protocol
Vlan1                  10.1.1.3        YES manual up                    up
!
Sw3#ping 10.1.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
!
Sw3#ping 10.1.1.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/4/4 ms

As required by the task, verify establishment of a telnet session from Sw2 and Sw3.

Sw2#telnet 10.1.1.1
Trying 10.1.1.1 ... Open


User Access Verification

Password: 
Sw1>enable
Password: 
Sw1#
!
!
Sw3#telnet 10.1.1.1
Trying 10.1.1.1 ... Open


User Access Verification

Password: 
Sw1>enable
Password: 
Sw1#

We can also verify this by using the show users command to determine who is connected to Sw1 via telnet. Basically, it tells us who is connected to the telnet server using a telnet session.

Sw1#show users
    Line       User       Host(s)              Idle       Location
*  0 con 0                idle                 00:00:00   
   1 vty 0                idle                 00:02:11 10.1.1.2
   2 vty 1                idle                 00:01:19 10.1.1.3
^ back to top